[Tig] MKIII Turbo not loading film in normal mode, loop OK

Benjamín Fernández Maribona benjamin at digitalsprockets.net
Thu Aug 14 00:01:26 BST 2008


Hello
I'm having trouble with my MKIII Turbo, it's not loading the film  
correctly in normal mode, in loop mode it loads perfect.
I clenead as other times the cell and
leds on the back, that control the right hand side tension arm, but no
luck, repleaced all the transistors 2n3442 on the spooling control, and
the 2n3055 on the capstan servo output board on the back next to the PECS
housing, nothing, cheked the voltages on load normal board 743A. Tried  
with other 743a Board, nothing
strange according to the manual on the voltages.
In the loop mode it works OK but in run mode
it is not able to load the film properly.
This has happened before and it was solved by cleaning the cell and the  
leds on the tension arm box on the back.
I also cheked the fuses.
Hope you can help me solve this problem.
Thanks
-- 
Visite www.digitalsprockets.net
Visit www.digitalsprockets.net




More information about the Tig mailing list